Discussion:
[hyperref]: Wrong luatex version in PDF creator field
Add Reply
Uwe Siart
2018-11-17 09:29:56 UTC
Reply
Permalink
This is observed with lualatex in TL18 and hyperref 2018/09/30 v6.88a.

When hyperref is loaded the PDF creator field in the produced PDF
contains "LuaTeX-1.7.0" whereas LuaTeX says about itself it's "1.07.0".
Without hyperref the creator field says (correctly?) "LuaTeX-1.07.0".

MWE to reproduce:

\documentclass{article}
\usepackage{hyperref}
\begin{document}
Test
\end{document}

Loading hyperref with option [luatex] doesn't change anything.
--
Uwe
Ulrike Fischer
2018-11-17 10:15:11 UTC
Reply
Permalink
Post by Uwe Siart
This is observed with lualatex in TL18 and hyperref 2018/09/30 v6.88a.
When hyperref is loaded the PDF creator field in the produced PDF
contains "LuaTeX-1.7.0" whereas LuaTeX says about itself it's "1.07.0".
Without hyperref the creator field says (correctly?) "LuaTeX-1.07.0".
The creator field says "TeX" without hyperref and "LuaTeX with
hyperref" with hyperref.

The field you mean it the producer field. And yes it is wrong.
Probably hyperref shouldn't set it at all. I will check in the
afternoon.
--
Ulrike Fischer
https://www.troubleshooting-tex.de/
Uwe Siart
2018-11-17 10:35:57 UTC
Reply
Permalink
Post by Ulrike Fischer
The field you mean it the producer field.
Ah, yes, absolutely right. Sorry for that. The terms "creator" and
"producer" have a great potentiality to create confusion.
--
Uwe
Ulrike Fischer
2018-11-17 17:08:41 UTC
Reply
Permalink
Post by Uwe Siart
Post by Ulrike Fischer
The field you mean it the producer field.
Ah, yes, absolutely right. Sorry for that. The terms "creator" and
"producer" have a great potentiality to create confusion.
The code as been corrected by David in the sources:
https://github.com/ho-tex/hyperref/commit/c79c72fb6f9770644d86091254c0f0b60fb8db11
--
Ulrike Fischer
https://www.troubleshooting-tex.de/
Loading...