Discussion:
problems with kp-fonts under MikTeX
(too old to reply)
Dr Engelbert Buxbaum
2018-08-29 17:33:10 UTC
Permalink
Hi,

after a new installation of my system I have problems with the kp-fonts.
pdfLaTeX calls metafont to translate jkpmite at 720 dpi in ljfour mode,
but doesn't succeed. MikTeX-makemf.log shows the following messages:
2018-08-29 18:18:42,192+0200 INFO miktex-makemf - starting with command
line: miktex-makemf.exe --verbose jkpmite
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - The jkpmite source
file could not be found.
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - The jkpmite source
file could not be found.
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - Info:
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - Source:
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - Line: 0

Similar problems arise with [artemisia]{textgreek}, while [euler] works.
Apparently, the sources are not installed, but MikTeX should install
them as needed (and actually does that with other packages).

Am I doing something wrong or is there a problem with font packages?

Sincerely

Engelbert
Dan Luecking
2018-08-29 18:27:03 UTC
Permalink
On Wed, 29 Aug 2018 19:33:10 +0200, Dr Engelbert Buxbaum
Post by Dr Engelbert Buxbaum
Hi,
after a new installation of my system I have problems with the kp-fonts.
pdfLaTeX calls metafont to translate jkpmite at 720 dpi in ljfour mode,
2018-08-29 18:18:42,192+0200 INFO miktex-makemf - starting with command
line: miktex-makemf.exe --verbose jkpmite
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - The jkpmite source
file could not be found.
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - The jkpmite source
file could not be found.
2018-08-29 18:18:42,207+0200 FATAL miktex-makemf - Line: 0
Similar problems arise with [artemisia]{textgreek}, while [euler] works.
Apparently, the sources are not installed, but MikTeX should install
them as needed (and actually does that with other packages).
There are no metafont sources for jkpmite, but there is jkpmite.pfb,
a PostScript type 1 font file, and its font metrics file jkpmite.tfm.
If the kpfonts are correctly installed, there should exist a line
something like

jkpmite Kp-Expert-Italic " KPFonts-Expert ReEncodeFont "
<kpfonts-expert.enc <jkpmite.pfb

(all on one line) in pdftex.map that instructs pdflatex how to use
the .pfb when the corresponding .tfm is asked for. A metafont source
file is not needed and should only be searched for as a last ditch
attempt when this process fails.

I suppose it is possible that the full kfonts distribution is not
included in your miktex or maybe the map files were not successfully
updated. Consult your MiKReX documentation on either installing or
updating kpfonts and (re)creating the font maps.

Artemesia should be similar to kpfonts.

The euler fonts exist as both PostScript type 1 (for which sources are
not needed) and as metafont sources (used only if the type 1 files are
not installed).

(Disclaimer: I do not currently use MiKTeK.)
Post by Dr Engelbert Buxbaum
Am I doing something wrong or is there a problem with font packages?
Something is wrong with the intallation of kpfonts and artemisia.
Perhaps they are not installed at all.

Dan
To reply by email, change LookInSig to luecking
Ulrike Fischer
2018-08-30 10:48:14 UTC
Permalink
Post by Dr Engelbert Buxbaum
Am I doing something wrong or is there a problem with font packages?
Run in the tasks menu of the miktex console (user mode) "refresh
font map files"

(Untested as you didn't provide an example).
--
Ulrike Fischer
https://www.troubleshooting-tex.de/
Loading...